Quante volte un certo mese si ripete in una gamma di date

La funzione complessa che andremo ad esaminare  utlizza per il tramite di MATR.SOMMA.PRODOTTO la gamma di date comprese nell’intervallo A1:A5. Il nostro scopo è quello di contare quante volte occorre nell’intervallo il mese di maggio, che verrà convertito in vero o falso dalla funzione NUM() e rappresentato nella formula dal numero =5. La traduzione in vero o falso può essere anche ottenuta con l’utilizzo di — in luogo di NUM()

=MATR.SOMMA.PRODOTTO(NUM(MESE(A1:A5)=5))

conta il numero di mesi di certe date